Did something change with the editor?


#1

I wonder if something recently changed with the editor? I’m finding an odd behavior related to backspacing (deleting words) and attempting to get the next line pressing enter/return.

I’ve taken a screencast of what’s happening for me, is this happening for anyone else? I feel like the change happened about 1-2 weeks ago.

http://screencast-o-matic.com/watch/cbfIcsXnxn

Thanks,

kevin


#2

Hi,

That is indeed a strange behavior. I do not experience this myself. What browser and operating system are you using? Does it happen with all browsers?

Independent of this, I suggest that you clear your browser cache and restart the browser to see if that will help.


#3

Hey Nitai,

I’ve confirmed this is a REAL issue, not just something that’s going on with my computer. I tested with my wife’s Mac and found the same issue to be happening with her separate Helpmonks account.

Here’s what I found:

  1. It ONLY happens on Chrome or Safari, not Firefox - so far, I’ve only tested on a Mac, not Windows + Chrome
  2. It happens ONLY on replies, not new messages.
  3. It started happening about a month ago after some recent help monks updates to the interface.
  4. Clearing browser cache does not affect it.

Thanks!


#4

Just to note: it’s really an annoying issue - it takes me almost twice as long now to write replies because I’m not used to it’s weird behavior. I’ll try to see if I can repeat the issue in Windows and let you know if I find it happening there too.


#5

Hi,

I’m sorry, but we cannot replicate this in any way. Also, you are the only one experiencing this. Could it be that you have some sort of extension enabled? Can you start the browser without any extensions?

Also, please clear your browser and cookie cache and try it again. If that doesn’t help, please open the developer console and see if there are any error when you type. However, I believe something is interfering with the editor.


#6

Nitai,

I don’t know what’s going on in that you cannot replicate this. It’s possible it could be just me, sure. However, I’m also a developer so I’m not a complete newbie at trying to replicate issues making sure I’m working in different environments.

For example, I recorded the following screencast in a brand new Windows install. Before recording this, I did a brand new install of Chrome and DID NOT login to my google account on it, so as to prevent any personal information or settings from being synced into the account. You can see in the video that sometimes the problem appeared and sometimes it did not. Finally, it was done on Windows, vs Mac - wherein both OS’s I’ve experienced the problem.

I don’t know that its a problem many people would bother reporting, because it’s not a all-or-nothing issue - one can continue to get work done and send emails, it’s just a bother.

http://screencast-o-matic.com/watch/cbhD3NXyAn

Would appreciate if anyone else could chime in if they’re experiencing this as as well.


#7

By the way, what’s the default browser you’re using Nitai?

Thanks


#8

We’ve looked further into this and by accident could replicate it. It has to do something how the editor creates new lines. In any case, I’ve changed this now and it seems to have fixed the issue.

We will update our servers in the coming 48 hours with the fix.


#9

Hey Nitai - You’re awesome -thanks so much for looking into the issue! So happy!


#10

Fyi: We will update our servers in the next 24 hours.


#11

Hi there,

This problem has come back for me. This appears to be the 2nd time it’s made a comeback. Could you please look into this issue?

https://screencast-o-matic.com/watch/cFhicGbTHO

Thanks,

kevin


#12

You already reported this to us by email…


#13

Hi Kevin,

We’ve tested this now with multiple operating systems and browsers. In addition, we also contacted the vendor. All of of, cannot replicate the issue you are seeing.

The recommendation at this point is to completely flush the browser cache, remove all cookies and try again.

I understand this is not what you expect, but it’s extremely difficult to pinpoint the issue when we cannot replicate it and also when you are the only one experiencing this.

Thank you.


#14

To be clear, I dont know why this thread from ANOTHER company is coming to chloe@pilot.com… please take me off of these :frowning:


#15

I also am getting this for an unknown reason.


#16

Hi,

This is the FORUM and you are automatically subscribed to it. You can sign in and change the notification


#17

Well, it would seem the devs have tried, but they’re not able to replicate it.

Could it be that this issue is specific to Mac? Are any of the Devs Mac users? If not, perhaps that could be why they’re having no problems when using Chrome? I also see no problems when I login to my Android on Chrome either, only when I use Chrome or Safari on my Mac. (if I’m not mistaken Chrome and Safari share similar code?)

I have finally found that it does not happen on Firefox. I guess I’ll be forced to use Firefox now just to deal with emails, as this problem seems like it’s not happening to enough people.

All I know is that while it’s not a critical issue, it’s an issue that has driven me me crazy as absolutely no other website has ever done this to me, so I have to learn how to type in a new way just for Helpmonks.

Hope Firefox works for anyone dealing with this.

Thanks all!


#18

Hi,

We actually use Mac’s (and also Windows) and we tried on all operating systems (including Linux) and with all browsers. We really can’t replicate the issue. The one in the past we could, and the provider fixed it, but your new issue cannot be replicated by all of us. Sorry.


#19

Well thanks for trying!


#20

Hi Kevin,

I’m following up on the issue you were seeing in the editor.

We’ve made some updates to the editor lately and also changed how text is being parsed. We are hopeful that this also solved your issue. Would you mind trying again and letting us know, please?